Debian 13 trixie

Podman : 一般ユーザーで利用する2025/08/22

 

一般ユーザーでも [Podman] コマンドは利用可能です。

[1] デフォルトで、ユーザー名前空間で使用される サブ UID/GID が一般ユーザーに割り当てられます。
# デフォルトの名前空間の数

root@dlp:~#
cat /proc/sys/user/max_user_namespaces

63758
# サブ UID/GID マッピング ファイルは以下
# [100000:65536] ⇒ [debian] ユーザーは コンテナー内では
# 100000~165535 (100000 + 65536 - 1) の間の UID がプロセスの実行に使用される

root@dlp:~#
cat /etc/subuid

debian:100000:65536
root@dlp:~#
cat /etc/subgid

debian:100000:65536
# ユーザーを新規追加すると サブ UID/GID マッピング ファイルにも自動で登録される
# コンテナー内でプロセスの実行に使用される UID が各ユーザー間で重複しないように
# n=0, n++ とすると
# [開始 UID/GID = 100000 + (65536 * n)]
# [終了 UID/GID = (開始 UID/GID) + 65536 - 1] となる

root@dlp:~#
adduser bookworm

root@dlp:~#
adduser trixie

root@dlp:~#
cat /etc/subgid /etc/subgid

debian:100000:65536
bookworm:165536:65536
trixie:231072:65536
debian:100000:65536
bookworm:165536:65536
trixie:231072:65536
[2] 一般ユーザーで [podman] 使用可能です。
debian@dlp:~$
podman pull debian

debian@dlp:~$
podman images

REPOSITORY                TAG         IMAGE ID      CREATED      SIZE
docker.io/library/debian  latest      047bd8d81940  11 days ago  124 MB

debian@dlp:~$
podman run debian echo "run rootless containers"

run rootless containers
# コンテナー関連ファイルは [$HOME/.local] 配下に保存される

debian@dlp:~$
ll ~/.local/share/containers/storage

total 156
-rw-r--r-- 1 debian debian 122880 Aug 22 10:22 db.sql
-rw-r--r-- 1 debian debian      8 Aug 22 10:22 defaultNetworkBackend
drwx------ 2 debian debian   4096 Aug 22 10:22 libpod
drwx------ 2 debian debian   4096 Aug 22 10:22 networks
drwx------ 5 debian debian   4096 Aug 22 10:22 overlay
drwx------ 3 debian debian   4096 Aug 22 10:22 overlay-containers
drwx------ 3 debian debian   4096 Aug 22 10:22 overlay-images
drwx------ 2 debian debian   4096 Aug 22 10:22 overlay-layers
-rw-r--r-- 1 debian debian     64 Aug 22 10:22 storage.lock
-rw-r--r-- 1 debian debian      0 Aug 22 10:22 userns.lock
drwx------ 2 debian debian   4096 Aug 22 10:22 volumes

# Pod も作成可

debian@dlp:~$
podman pod create -p 8081:80 -n test-pod

debian@dlp:~$
podman pod ls

POD ID        NAME        STATUS      CREATED        INFRA ID      # OF CONTAINERS
e2db14b02995  test-pod    Created     4 seconds ago  735e59f65179  1

# ポートマッピングについては
# 一般ユーザーでは ホスト側の [1024] 未満のポートは使用不可
# [1024] 以上は使用可

debian@dlp:~$
podman run -itd -p 1023:80 debian /bin/bash

Error: pasta failed with exit code 1:
Failed to bind port 1023 (Permission denied) for option '-t 1023-1023:80-80'
debian@dlp:~$
podman run -itd -p 1024:80 debian /bin/bash

debian@dlp:~$
podman ps

CONTAINER ID  IMAGE                            COMMAND     CREATED        STATUS        PORTS                 NAMES
81c9cd6a7fd0  docker.io/library/debian:latest  /bin/bash   2 seconds ago  Up 2 seconds  0.0.0.0:1024->80/tcp  nice_shamir
関連コンテンツ