Ubuntu 16.04
Sponsored Link

OpenStack Pike : Pre-Requirements
2017/09/01
 
This is the exmaple of Cloud Computing by OpenStack.
Install some services which some components of OpenStack needs for system requirements on here.
This example is based on the environment like follows.
                  eth0|10.0.0.30 
          +-----------+-----------+
          |    [ Control Node ]   |
          |                       |
          |  MariaDB    RabbitMQ  |
          |  Memcached            |
          +-----------------------+

[1]
[2]
[3] Install Openstack Pike repository.
root@dlp:~#
apt-get -y install software-properties-common

root@dlp:~#
add-apt-repository cloud-archive:pike

root@dlp:~#
apt-get update

root@dlp:~#
apt-get -y upgrade

[4] Install RabbitMQ and Memcached.
root@dlp:~#
apt-get -y install rabbitmq-server memcached python-pymysql
# add a user (set any password for "password" section)

root@dlp:~#
rabbitmqctl add_user openstack password

Creating user "openstack" ...
root@dlp:~#
rabbitmqctl set_permissions openstack ".*" ".*" ".*"

Setting permissions for user "openstack" in vhost "/" ...
root@dlp:~#
systemctl restart rabbitmq-server
root@dlp:~#
vi /etc/mysql/mariadb.conf.d/50-server.cnf
# line 29: change

bind-address =
0.0.0.0
# line 105: change

character-set-server =
utf8

#
kcollation-server = utf8mb4_general_ci
root@dlp:~#
systemctl restart mysql
root@dlp:~#
vi /etc/memcached.conf
# line 35: change

-l
0.0.0.0
root@dlp:~#
systemctl restart memcached
Matched Content
 
Tweet